镜像域名: doub.bid 提供给无翻墙能力的人使用~ 有能力的建议访问主域名("点"改为".") doub点io
投稿文章 | 广告投放 | Telegram 群组 / 公告频道

『原创』Debian/Ubuntu TCP拥塞控制技术 ——TCP-BBR 一键安装脚本

Shell脚本 Toyo 127评论
本文最后更新于 2017年8月13日 11:12 可能会因为没有更新而失效。如已失效或需要修正,请留言!

这几天很火的BBR,我研究了一下,写了一个一键脚本,适合新手使用。


手动安装方法:比锐速还强的 TCP拥塞控制技术 —— TCP-BBR 测试及开启教程

注意:TCP-BBR和锐速一样,不支持Openvz,查看本教程之前,请先确定你的VPS的虚拟化技术!

注意:本教程涉及到VPS更换内核,所以如果步骤错误,或者VPS不兼容最新的内核,会导致无法开机等错误,请勿用于生产环境!!!!

BBR 简单介绍

BBR 是一个由谷歌社区开发的 TCP拥塞控制技术,目前处于开发初期,但是前景很棒,大家可以持续关注,同时BBR是集成与Linux最新版本的内核中的。

具体什么是TCP拥塞控制技术,详细的我也不懂,我就用通俗一点的话解释一下,不一定准确,看一看理解一下就好了。

原始的TCP流量传输,已经不能适应现在的互联网了,我们把 TCP流量比喻成 公路上的汽车流量,而TCP传输隧道就是 公路,那么:

在原始的TCP流量传输中,一条十字路口公路,很多车流量,但是却没有红绿灯和交警,导致大家左挤右挤的堵车了,这就是没有合理的管理导致的。

而BBR和锐速等TCP流量控制技术,就是红绿灯+交警,他们就是在无人管理的十字路口,去合理指挥分配车流量,然后最大化的利用车流量,保证路面畅通。

大概就是这样解释了,有什么错误请指出。

BBR官方项目地址:https://github.com/google/bbr

系统要求

Debian / Ubuntu 14.04 +

CentOS用户请使用这个脚本:CentOS/Debian/Ubuntu系统 TCP-BBR 一键安装脚本

本脚本只在 Debian 7 / Debian 8 / Ubuntu 14.04 / Ubuntu 16.04 (均 x64位) 这几个系统中测试过脚本可以正常运行(Vultr)!

强烈推荐 Debian 7 x64,这个是我一直使用的系统,我的脚本在这个系统上面出错率最低。

至于为什么不支持 CentOS 等系统,主要是我不怎么用其他的系统,就不做支持了。

脚本版本

Ver: 1.0.15

脚本已知BUG,当遇到内核版本为 X.XX 格式的时候(例如 4.12这样),会因为下载站上面的文件名(4.12)和安装后的内核版本(4.12.0)不同,而导致提示内核不是最新版本啥的,不用管这个,无视即可,不影响使用。

安装步骤

更换内核需要ROOT权限,所以如果你是普通用户 的话,需要ROOT账号权限,如果你是ROOT账号,那就忽略这个步骤

sudo su

输入并回车后,会提示让你输入当前账号的密码,输入并回车后就可以继续下面的步骤了。

wget -N --no-check-certificate https://softs.fun/Bash/bbr.sh && chmod +x bbr.sh && bash bbr.sh

备用下载地址(上面的链接无法下载,就用这个):

wget -N --no-check-certificate https://raw.githubusercontent.com/ToyoDAdoubi/doubi/master/bbr.sh && chmod +x bbr.sh && bash bbr.sh

下载并运行脚本后,会自动检测并开始安装,首先会提示你输入要下载的内核版本,可以安装自定义版本的内核,也可以直接回车安装最新版本的内核内核版本获取)!

请输入 要下载安装的Linux内核版本(BBR) [ 格式: x.xx.xx ,例如: 4.10.12 ]
 [注意]内核版本列表请去这里获取:[ http://kernel.ubuntu.com/~kernel-ppa/mainline/ ]
(默认回车,自动获取最新版本):4.10.10

注意:在Debian系统中,删除旧内核时,会提示你是否终止删除内核的行为(如下图),这个需要你选择 <No> (键盘方向键 选择,回车键 确认)。

如果没有出错,内核更换完毕后,会提示是否立即重启VPS,直接回车或者输入 Y

需要重启VPS后,才能开启BBR,是否现在重启 ? [Y/n] : y
[注意]  重启VPS后,请重新运行脚本查看BBR是否加载成功 bash bbr.sh status

[信息]  VPS 重启中...

等待十几秒,VPS启动后,重新通过SSH连接VPS,进入 bbr.sh 脚本的目录,然后执行下面这个命令查看BBR是否加载成功。

bash bbr.sh status

然后就会自动开启BBR。

如果重启VPS后,无法连接,说明内核安装或与系统存在兼容性问题,无法正常启动,代表你的VPS当前系统无法使用BBR,请更换其他系统!

使用方法

# 启动BBR
bash bbr.sh start

# 关闭BBR
bash bbr.sh stop

# 查看BBR状态
bash bbr.sh status
注意:关闭BBR,需要重启VPS,所以脚本会提醒是否立即重启VPS。

升级BBR

bash bbr.sh
# 重新执行脚本会检测最新内核和当前内核,对比版本

因为BBR只是内核中的一段功能代码,所以内核更新不一定是BBR更新,就像Win10中IE的位置一样,Win10更新不代表是为了更新IE,所以是否要更新内核要看BBR官方源码有没有更新了。

BBR官方项目地址:https://github.com/google/bbr

注意BBR源码最后更新时间,如果比你的内核新,那么你可以更新内核,反之无需更新。

卸载BBR

BBR集成于内核中,所以卸载BBR=更换内核,教程:

Debian/Ubuntu 内核降级教程 —— 降低(BBR)为支持锐速的内核版本

其他说明

注意:TCP-BBR必须是 2016-12-05 21:00 更新的 4.9.0-rc8 内核及以后的版本 才能开启,而锐速并不支持这个最新的内核版本,所以TCP-BBR和锐速是不可能共存的。

裸SS / 锐速+SS / BBR+SS简单速度对比,仅供参考,看这里

更换内核后重启服务器无法启动 的问题

如果重启VPS后,无法连接,说明内核安装有问题 或 内核与系统存在兼容性问题,无法正常启动。

这代表你的VPS当前系统不支持最新的内核版本,无法开启BBR,请更换其他系统尝试!

提示 wget: unknown host “softs.fun” 之类的错误

这是无法解析我的域名,多半是DNS的问题,请更换DNS为谷歌DNS。

echo "nameserver 8.8.8.8" > /etc/resolv.conf
echo "nameserver 8.8.4.4" >> /etc/resolv.conf

提示 wget: command not found 的错误

这是你的系统精简的太干净了,wget都没有安装,所以需要安装wget。

# Debian/Ubuntu 系统:
apt-get install -y wget

更新日志

2017年08月05日,版本 v1.0.15

1.新增 i686系统支持(32位 i386分支)。

点击展开 查看更多更新日志


如果有什么BUG,请联系我或者在下面评论留言!

允许转载,但是请注明源链接,谢谢!

转载请超链接注明:逗比根据地 » 『原创』Debian/Ubuntu TCP拥塞控制技术 ——TCP-BBR 一键安装脚本
责任声明:本站一切资源仅用作交流学习,请勿用作商业或违法行为!如造成任何后果,本站概不负责!

赞 (39)or打赏
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(127)个小伙伴在吐槽
  1. 安装第一步就是
     /boot/vmlinuz-4.12.6-041206-generic
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-4.12.6-041206-generic
    Found initrd image: /boot/initrd.img-4.12.6-041206-generic
    Found linux image: /boot/vmlinuz-3.2.0-4-amd64
    Found initrd image: /boot/initrd.img-3.2.0-4-amd64
    Segmentation fault
    
    Message from syslogd@localhost at Aug 15 08:07:55 ...
     kernel:[  158.822899] general protection fault: 0000 [#1] SMP
    
    Message from syslogd@localhost at Aug 15 08:07:55 ...
     kernel:[  158.824017] Stack:
    
    Message from syslogd@localhost at Aug 15 08:07:55 ...
     kernel:[  158.824017] Call Trace:
    
    Message from syslogd@localhost at Aug 15 08:07:55 ...
     kernel:[  158.824017] Code: 83 c4 18 5b 5d 41 5c 41 5d 41 5e 41 5f c3 49 8b 7f 10 e8 67 51 04 00 eb d9 48 8b 47 10 48 8b 50 28 48 85 d2 75 05 48 83 c0 30 c3  e2 55 48 89 d5 53 48 89 f3 41 52 48 8b 7f 68 e8 d9 ff ff ff
    
    用的你推荐的系统,重装几遍系统一样问题,只能装锐速。始终装不了bbr
    永远的问题2017-08-16 00:30 (4天前)回复
    • 应该是系统不支持或者其他方面有限制。
      Toyo2017-08-16 00:38 (4天前)回复
  2. Linodes的VPS好像用不了这个一键脚本啊,一直提示[错误] 检测到 BBR 已开启但未正常启动,请检查 !
    兔姬菌2017-08-13 10:16 (7天前)回复
    • Linode 更换内核似乎需要在后台调整什么才行。
      Toyo2017-08-13 10:50 (7天前)回复
    • 进Linode管理页面按edit 看到内核选GRUB 2 保存后reboot下,再执行bash bbr.sh status。亲测 :mrgreen:
      orzsix2017-08-17 00:09 (3天前)回复
  3. ubuntu 16.04 64bits 重启后不能连接ssh,试过好几次都是这样的,望大神看看是什么问题
    linux小白2017-08-04 17:22 回复
    • 谷歌GCE或亚马逊AWS的服务器?打开脚本,注释第651行的 Set_iptables (前面加上 # 号),只知道这两家的服务器可能因为我基本里设置防火墙的原因而无法开机启动,暂无解决方法,只能注释掉代码,缺点是 无法保存防火墙规则。
      Toyo2017-08-04 17:30 回复
      • 不是,我用的是seedbox,法国op盒子,刚刚也试了下,装的ubuntu 14.04的系统,还是一样的问题,不知道是不是个例,前面都没有啥问题,就是重启之后就不能通过ssh连接vps了 :???:
        linux小白2017-08-04 18:24 回复
      • 是不是安装的过程中改了登录ssh的端口? :lol:
        linux小白2017-08-04 19:50 回复
        • 尴尬,我回复错评论了,你这个更换支持BBR的内核后重启,然后无法开机的,多半是因为未知原因不兼容等问题导致内核无法启动,这种问题还是重装换个系统吧。
          Toyo2017-08-04 22:06 回复
          • ubuntu 14/16两个版本都不能开机,好忧伤啊,也不知道什么问题 :???:
            linux小白2017-08-05 13:26 回复
          • 换debian7就可以安装并且可以开机 :grin:
            linux小白2017-08-05 14:37 回复
  4. debian8 x64mini,脚本执行过程提示Segmentation faul,卡住。ctrl+c跳过,居然也能安装成功。
    cie2017-08-04 14:16 回复
  5. :1
    请输入 要下载安装的Linux内核版本(BBR) [ 格式: x.xx.xx ,例如: 4.10.12 ]
    [注意] 内核版本列表请去这里获取:[ http://kernel.ubuntu.com/~kernel-ppa/mainline/ ]
    (默认回车,自动获取最新版本):
    [信息] 检测内核最新版本中...
    [信息] 当前内核最新版本为 : 4.12.4
    
    [信息] 检测到 当前内核版本 已是最新版本,无需继续安装 !
    [信息] 检测到内核数量异常,存在多余内核,开始删除...
    [信息] 检测到 2 个其余内核,开始卸载...
    [信息] 开始卸载 linux-image-3.2.0-4-amd64 内核...
    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    [信息] 卸载 linux-image-3.2.0-4-amd64 内核卸载完成,继续...
    [信息] 开始卸载 linux-image-3.2.0-4-amd64
    linux-image-amd64 内核...
    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    [信息] 卸载 linux-image-3.2.0-4-amd64
    linux-image-amd64 内核卸载完成,继续...
    [错误] 内核卸载异常,请检查 !
    
    xuudue2017-07-30 08:55 回复
    • 估计你在卸载默认内核linux-image-3.2.0-4-amd64时,出现什么问题导致卸载中断,执行 dpkg –configure -a 后再尝试,同时查看系统内核是否有 卸载linux-image-3.2.0-4-amd64内核的命令在运行,如果有 kill -9 PID结束掉。
      Toyo2017-07-30 13:30 回复
  6. [信息] 检测内核最新版本中...
    [信息] 当前内核最新版本为 : 4.12.4
    
    [信息] 检测到 当前内核版本 不支持开启BBR,开始安装...
    
    ........
    
    root@debian:~# bash bbr.sh status
    [信息] 检测内核最新版本中...
    [信息] 当前内核最新版本为 : 4.12.4
    [信息] 检测到 内核版本 已满足要求,继续...
    [信息] 检测到 BBR 已开启 !
    [信息] 检测到 BBR 已开启并已正常启动 !
    
    --------------------------------------------------------------
    4.12.4 提示不支持,继续安装后还是能正常开启。。。
    doubi2017-07-29 22:10 回复
    • 什么系统?具体什么操作步骤才会触发这个BUG?我测试了几次没见到这个问题。
      Toyo2017-07-30 00:34 回复
  7. 4.12.4显示不支持,需要更换内核吗
    iluje2017-07-29 00:55 回复
    • 什么意思,请出示详细信息。
      Toyo2017-07-29 01:09 回复
  8. 最新內核4.12.2會卡機!!!!!!
    Ken2017-07-18 21:15 回复
    • 并不会,今天我还给6个小鸡装了BBR,都是最新的4.12.2,都正常 Ubuntu14.04 Debian8 。
      Toyo2017-07-19 00:46 回复
      • 我Debian 7 x64,裝在虛擬機上,內核4.12.2會卡死,換4.9的就沒事了
        Ken2017-07-19 21:04 回复
        • 虚拟机?
          Toyo2017-07-20 00:25 回复
          • 簡單說就是虛擬技術是VM-Ware
            Ken2017-07-23 19:37 回复
  9. 首先,感谢博主的贡献!在博主的博客中试了2个方案,不知何故,一直有问题,博主也迅速给了回复。无奈本人完全小白搞不定,只得又换方案,这个一试OK.分享给后面的XDJM: Linode,Ubuntu 14, 64位,安装博主的“CentOS/Debian/Ubuntu ShadowsocksR 单/多端口 一键管理脚本”; 安装后检查 BBR状态,最后两行提示,一条说启动正常,另一条说启动错误;但加速不受影响;VPS重启后,也正常; 再次谢谢博主
    Chur2017-07-17 11:27 回复
  10. 检测到 BBR 已开启但未正常启动,请检查 !
    clover2017-06-23 15:43 回复
  11. debian7 64,装过脚本正常,后来手工搞过XanMod的内核,今天内核更新,继续用本站脚本,发觉报错了:
    4.9.31:
    请输入 要下载安装的Linux内核版本(BBR) [ 格式: x.xx.xx ,例如: 4.10.12 ]
    [注意] 内核版本列表请去这里获取:[ http://kernel.ubuntu.com/~kernel-ppa/mainline/ ]
    (默认回车,自动获取最新版本):4.9.31
    
    [信息] 检测到 当前内核版本 不是最新版本,升级(或降级)内核...
    --2017-06-07 20:51:32--  http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.9.31/
    Resolving kernel.ubuntu.com (kernel.ubuntu.com)... 91.189.94.216
    Connecting to kernel.ubuntu.com (kernel.ubuntu.com)|91.189.94.216|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: `linux-image-4.9.31-amd64.deb'
    
        [                                                                ] 3,591       --.-K/s   in 0s
    
    2017-06-07 20:51:33 (45.0 MB/s) - `linux-image-4.9.31-amd64.deb' saved [3591]
    
    [信息] 内核文件下载成功,开始安装内核...
    dpkg-deb: error: `linux-image-4.9.31-amd64.deb' is not a debian format archive
    dpkg: error processing linux-image-4.9.31-amd64.deb (--install):
     subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
     linux-image-4.9.31-amd64.deb
    [错误] 检测到 内核版本 安装失败,请检查 !
    
    
    
    4.11.4:
    Resolving softs.fun (softs.fun)... 69.12.67.44
    Connecting to softs.fun (softs.fun)|69.12.67.44|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 8564 (8.4K) [application/octet-stream]
    Server file no newer than local file `bbr.sh' -- not retrieving.
    
    请输入 要下载安装的Linux内核版本(BBR) [ 格式: x.xx.xx ,例如: 4.10.12 ]
    [注意] 内核版本列表请去这里获取:[ http://kernel.ubuntu.com/~kernel-ppa/mainline/ ]
    (默认回车,自动获取最新版本):
    [信息] 检测内核最新版本中...
    [信息] 当前内核最新版本为 : 4.11.4
    
    [信息] 检测到 当前内核版本 不是最新版本,升级(或降级)内核...
    --2017-06-07 20:52:26--  http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.11.4/
    Resolving kernel.ubuntu.com (kernel.ubuntu.com)... 91.189.94.216
    Connecting to kernel.ubuntu.com (kernel.ubuntu.com)|91.189.94.216|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: `linux-image-4.11.4-amd64.deb'
    
        [                                                                ] 3,483       --.-K/s   in 0.001s
    
    2017-06-07 20:52:26 (2.43 MB/s) - `linux-image-4.11.4-amd64.deb' saved [3483]
    
    [信息] 内核文件下载成功,开始安装内核...
    dpkg-deb: error: `linux-image-4.11.4-amd64.deb' is not a debian format archive
    dpkg: error processing linux-image-4.11.4-amd64.deb (--install):
     subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
     linux-image-4.11.4-amd64.deb
    [错误] 检测到 内核版本 安装失败,请检查 !
    
    请问是提示的error: `linux-image-4.11.4-amd64.deb' is not a debian format archive的问题,还是因为我手工搞过的影响呢?
    Me22017-06-07 20:57 回复
    • 等不及,先折腾了Debian8 64,用了 jessie-backports源的Debian 4.9.25-1~bpo8+1来跑,没用最新的了。
      Me22017-06-08 01:22 回复
  12. Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libuuid-perl linux-base
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
      linux-image-3.2.0-4-amd64*
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    After this operation, 106 MB disk space will be freed.
    (Reading database ... 47773 files and directories currently installed.)
    Removing linux-image-3.2.0-4-amd64 ...
    Aborting removal of running kernel image.
    dpkg: error processing linux-image-3.2.0-4-amd64 (--purge):
     subprocess installed pre-removal script returned error exit status 1
    Errors were encountered while processing:
     linux-image-3.2.0-4-amd64
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    [信息] 卸载 linux-image-3.2.0-4-amd64 内核卸载完成,继续...
    [错误] 内核卸载异常,请检查 !
    root@R:~# dpkg -l|grep linux-image                          
    pi  linux-image-3.2.0-4-amd64           3.2.88-1                          amd64        
    ii  linux-image-4.11.1-041101-generic   4.11.1-041101.201705140931        amd64
    root@R:~# virt-what
    kvm
    
    这个旧内核删除怎么失败了呢?
    siam2017-05-18 10:19 回复
    • 尝试手动卸载试试:
      apt-get purge linux-image-3.2.0-4-amd64
      
      Toyo2017-05-18 11:44 回复
      • root@R:~# apt-get purge linux-image-3.2.0-4-amd64
        Reading package lists... Done
        Building dependency tree
        Reading state information... Done
        The following packages were automatically installed and are no longer required:
          libuuid-perl linux-base
        Use 'apt-get autoremove' to remove them.
        The following packages will be REMOVED:
          linux-image-3.2.0-4-amd64*
        0 upgraded, 0 newly installed, 1 to remove and 50 not upgraded.
        After this operation, 106 MB disk space will be freed.
        Do you want to continue [Y/n]? y
        (Reading database ... 41610 files and directories currently installed.)
        Removing linux-image-3.2.0-4-amd64 ...
        Aborting removal of running kernel image.
        dpkg: error processing linux-image-3.2.0-4-amd64 (--purge):
         subprocess installed pre-removal script returned error exit status 1
        Errors were encountered while processing:
         linux-image-3.2.0-4-amd64
        E: Sub-process /usr/bin/dpkg returned an error code (1)
        
        还是不能卸载喔
        siam2017-05-18 14:48 回复
        • 那就不清楚了,只能确定不是脚本问题,而是系统问题了。
          Toyo2017-05-18 17:09 回复
  13. 现在内核已经到4.11了,希望可以更新一下脚本。
    Sun2017-05-07 16:33 回复
    • 已经更新了脚本 v1.0.11 ,不过目前已知BUG是,获取的版本号是 4.11 ,而安装后本地查到的版本号是 4.11.0 会无法匹配,提示不是最新版本,无视就好。
      Toyo2017-05-07 17:16 回复
  14. 居然不支持i686哭QMQ
    scarletk2017-03-28 18:20 回复
  15. 写了一篇关于BBR算法原理的分析 https://www.nanqinlang.com/cwnd-control 上午写到现在 头好晕 我要去睡觉了。。。
    南琴浪2017-03-25 13:19 回复
  16. 非常感谢偷油的一键脚本,有一事请教! 我才申请的google一年的vps,最基础的debian版本,能否直接用这个脚本? 非常感谢!
    meisqq2017-03-23 07:43 回复
    • 可以,不过需要第一步去 先切换为 root用户,否则会各种权限不足,安装失败。
      Toyo2017-03-23 12:14 回复
      • 非常感谢,已经搞定! 不过有个问题,只要重启VPS,就要重新启动SSSERVER。 有没有自启动的脚本? 看了几个教程,运行命令 sudo vim /etc/rc.local 编辑自启动配置文件。加入代码 怎么加?在哪里加? 加完了之后怎么退出?按键盘没有反应 我是小白,不好意思!
        meisqq2017-03-23 12:38 回复
  17. 不知道是什么原因,vultr安装使用都很顺利,但是换成linode之后,使用ubuntu和debian都是安装内核成功,最后一步提示:检测到 BBR 已开启但未正常启动,请检查 !
    Akring2017-03-03 13:42 回复
    • linode,我记得是可以后台直接更换4.9.x内核的,反正需要在后台调整什么才行。
      Toyo2017-03-03 19:58 回复
  18. 安装运行之后提示 “检测到BBR已开启,但未正常启动,请检查!”,请问这个要怎么破呀?
    julian2017-03-03 09:55 回复
    • 这个说明你更换内核后,开启了BBR,但是BBR没有运行或无法运行。
      尝试手动开启:https://doub.io/wlzy-15/
      如果还不行,那么说明系统和内核不兼容。
      Toyo2017-03-03 12:55 回复
  19. 用秋水的脚本最新内核是4.10,用你的脚本检测最新还是4.9啊
    jaz2017-02-26 23:12 回复
    • 已经更新脚本支持 4.1x.x,之所以只检测到 4.9,是因为当时 4.10还是测试版,所以只检测到 4.9版本。这几天没看,没留意到 4.10正式版出来了。
      Toyo2017-02-27 10:35 回复
  20. Info: TCP BBR has been successfully installed. nothing to do... 站长,我的vps抽风之后我重启,然后查看bbr显示这样,是已经启动的意思么,vps重启之后ss和bbr需要不需要重新启动呢?
    大人看的片叫大片2017-02-20 15:46 回复
    • 你用的不是我的脚本。
      这句话的意思是BBR正常开启。
      BBR是集成于内核的,VPS启动时,会随内核一起启动,只要开启后就不用管了。
      Toyo2017-02-20 17:04 回复
  21. 据说openvz可以上bbr了
    ku ro ki to m ko2017-02-17 23:12 回复
    • 一、步骤麻烦,错误率很高。
      二、既然是卖OpenVZ的IDC,那就不喜欢让你在OpenVZ的VPS上面安装这个,大部分IDC发现后会封VPS的。
      三、我手里OpneVZ的机器很少,早就不买这种低价超售鸡了。
      Toyo2017-02-18 01:22 回复
      • 可以,反正我对openvz无感
        kurokitomoko2017-02-18 18:56 回复
  22. [信息] 检测内核最新版本中... [信息] 当前内核最新版本为 : 4.9.9 [信息] 检测到 内核版本 已满足要求,继续... sysctl: cannot stat /proc/sys/net/ipv4/tcp_available_congestion_control: No such file or directory sysctl: cannot stat /proc/sys/net/core/default_qdisc: No such file or directory sysctl: cannot stat /proc/sys/net/ipv4/tcp_congestion_control: No such file or directory sysctl: cannot stat /proc/sys/net/ipv4/tcp_available_congestion_control: No such file or directory [错误] BBR 启动失败,请检查 ! ------------------------------------------------------------ 博主,求解,是什么问题
    whythatme2017-02-11 13:49 回复
    • 你是,更换内核并重启后,输入 bash bbr.sh start 后提示的这个?
      Toyo2017-02-11 14:11 回复
      • 是的,输入这个start命令后,就报错了
        doubiNIHAO2017-02-11 14:12 回复
        • dpkg -l|grep linux-image | awk '{print $2}'
          # 看一下当前内核是否有 4.9.9,如果有就手动开启试试,看看有没有报错
          echo "net.core.default_qdisc=fq" >> /etc/sysctl.conf
          echo "net.ipv4.tcp_congestion_control=bbr" >> /etc/sysctl.conf
          sysctl -p
          # 如果还是报错,那可能还是内核安装有问题或者兼容性问题了,那我就不清楚了,建议重装其他系统测试。
          
          Toyo2017-02-11 15:11 回复
          • 有4.9.9,但是【sysctl -p】后报错:sysctl: cannot stat /proc/sys/net/core/default_qdisc: No such file or directory sysctl: cannot stat /proc/sys/net/ipv4/tcp_congestion_control: No such file or directory sysctl: cannot stat /proc/sys/net/core/default_qdisc: No such file or directory sysctl: cannot stat /proc/sys/net/ipv4/tcp_congestion_control: No such file or director ---------------------------------------------- 看来要换系统了,谢啦
            doubiNIHAO2017-02-11 15:17 回复
          • 真心搞不定,各种问题都有,希望博主可以写个樱花使用TCP BBR的教程,安装了SSR,但是加速不会添加,内核升级也搞不定,现在速度超级慢超级慢。
            doubiNIHAO2017-02-11 16:33 回复
            • 樱花Docker?算了,Docker是有诸多限制的,特别是樱花免费的Docker。
              Toyo2017-02-11 17:31 回复
              • 但是我看到有人说成功了,只是我怎么弄都不行,樱花应该是可以开启BBR的,推上还有人TCP也成功了,只是藏着不肯说,博主有空不妨试试啊
                doubiNIHAO2017-02-11 17:44 回复
                • 樱花Docker没劲,太烦,懒得玩。
                  Toyo2017-02-11 17:57 回复
              • 不过他们都在说,最近docker很火啊,博主也该尝尝鲜啦,樱花拿来练手很不错
                doubiNIHAO2017-02-11 17:59 回复
1 2